Unable to connect to LDAP - problem accessing trust store
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Unable to connect to LDAP - problem accessing trust store

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Article ID: 391581

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Updated On:

Products

ESP dSeries Workload Automation

Issue/Introduction

The DSeries Server may experience a problem connecting to the LDAPS server configured - resulting in the message/email: Unable to connect to LDAP server, configuration name: <name of ldap configuration added to DSeries>

Environment

DSeries 12.x

Cause

The permissions set on the truststore file used by DSeries is not set properly. The owner (or user starting the DSeries Server process) needs a minimum of read permissions. 

Resolution

Make sure that the user starting the DSeries Server has read permissions on the truststore used by DSeries to make an SSL handshake with the LDAPS server. 

Additional Information

When the permissions of the truststore file are not set properly, the following message will appear in the tracelog.txt:

Caused by: java.security.KeyStoreException: problem accessing trust store