Snmp.log file generated on Policy Server after upgrading to 12.8SP8
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Snmp.log file generated on Policy Server after upgrading to 12.8SP8

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Article ID: 391513

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Updated On:

Products

SITEMINDER

Issue/Introduction


The snmp feature is not configured on the Policy Server, but the snmp.log file is still getting generated and it's empty.

This is observed after upgrading the Policy Server to 12.8SP8CR01.  

 

Environment


Policy Server r12.8SP8CR01 and newer releases;

 

Cause


There was a change to the snmp librairies to the Policy Server 12.8SP8 release, which is causing this behavior since the log management for snmp is now handled within log4j2.properties (1).

 

Resolution


To stop the log from being generated, perform the below steps:

1. Backup the log4j2.properties found under /{home_policy_server}/config/properties;
2. Modify the log4j2.properties and set the logger.snmplogger.level to OFF;

Before change (out of the box):

#logger package org.snmp4j
logger.snmplogger.name = org.snmp4j
logger.snmplogger.level = INFO
logger.snmplogger.additivity = false
logger.snmplogger.appenderRef.rolling.ref = snmpRolling

After change:

#logger package org.snmp4j
logger.snmplogger.name = org.snmp4j
logger.snmplogger.level = OFF
logger.snmplogger.additivity = false
logger.snmplogger.appenderRef.rolling.ref = snmpRolling

 

Additional Information