Duplicate variable created in day-2 catalog items on ServiceNow integrated with Aria Automation
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Duplicate variable created in day-2 catalog items on ServiceNow integrated with Aria Automation

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Article ID: 391465

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Large number of duplicate variable seen created in ServiceNow with Aria Automation Integration, which may not be mapped to any deployments. 

 

Environment

Aria Automation 8.x

 

Cause

This is caused by a known issue with ServiceNow, When day-2 actions for multiple deployments are processed simultaneously, the duplicate variables may be generated in respective day-2 catalog items.

Resolution

Resolution:

  • This is not an issue caused by the ITSM Plugin or by Aria Automation, but due to a know issue with ServiceNow. 

Workaround:

  • To Workaround this issue, run the scheduled job "Delete Duplicates" in ServiceNow.
  • Note:
    • This job deletes the duplicate variables created in ServiceNow.
    • This scheduled job is disabled by default and would require to have the search filter of 'active=true' removed when searching for this scheduled job.

Additional Information