Aria Suite LCM shows vRealize Network Insight can no longer authenticate to Identity Manager's OAuth 2 Client
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Aria Suite LCM shows vRealize Network Insight can no longer authenticate to Identity Manager's OAuth 2 Client

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Article ID: 391405

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When using OAuth 2 integration for Aria Suite Products, the mapped Client ID and Client Secret is removed from IDM following events like:

  • Rebuild of Identity Manager Infrastructure
  • LDAP change to OAuth 2 Client  Authentication
  • Remote Access to Products used in Aria Suite LCM 
  • You observe the Aria Operations for Network Insight Environment Product no longer authenticating



  • The integration setup wizard is blank

 

Environment

Identity Manager 3.3.x

Aria Suite Lifecycle Manager 8.x

Aria Operations for Networks 6.12.x

Cause

The issue is caused by a missing OAuth Client ID and Client Secret inside Identity Manager's Remote Access Settings and Configurations

Resolution

1. Verify if there is existing Client  credentials, type , and scope of authentication inside Identity Manager for the service you are using with OAuth 2

2. Reapply the same settings inside Aria Suite LCM for your Aria product integration.

3. If no client record exists for your services and or Aria product integration , click the

4. Proceed with setup wizard to create new Client ID , Secret , and Thumbprint

5. Apply the new settings inside Aria Product integration page

Additional Information

Please see reference to Aria Operations for Networks and Configuring VMware Identity Manager access :

https://techdocs.broadcom.com/us/en/vmware-cis/aria/aria-operations-for-networks/6-11/vrealize-network-insight-ug-4-1-and-later-6-11/configuration/configuring-identity-and-access-management/user-management/import-vidm-users/configure-vidm-in-vrni.html