Why Project Task Start and Finish Dates Change
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Why Project Task Start and Finish Dates Change

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Article ID: 3914

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

There are times that the dates on tasks change.
The dates can be manually changed by a user, however it is unknown what else can cause the dates to update.

Steps to Reproduce:

Prerequisite: Check Allow Effort Task Creation in Administration > Project Management > Settings

1. Create a project with project dates in the past (Ensure track mode is set to PPM and the project is Open for Time Entry)
2. Add at least one resource to the Team tab of the project (This will create the effort task and automatically assign the resource to the task)
3. Post a timesheet for a date that is beyond the current project dates

Expected Results: Task dates do not change if time has not been submitted against them.

Actual Results: Review the task date and the dates should change based on the new 'Actuals Thru Date'

Environment

Clarity all supported versions 

Cause

This is working as designed.

Resolution

The reason  the 'Actuals Thru Date' on the task assignment is being updated is due to the Post Timesheets job processing timesheet actuals against the project task.

If the task assignment has ETC, this affects the task dates.

Even if the timesheet that is posted does not contain any entries for the task, this issue can occur. The reason is that a resource has posted time through a specific date.
As the task still has ETC, Clarity will adjust the dates accordingly as it considers the task still open due to the remaining ETC.

Workaround: The one option to workaround this behavior is to close the project for time entry by unchecking 'Open for Time Entry' at the project level.

Additional Information

The project finish date in Clarity PPM may get updated when the ETC under a task is updated because:

  • When assignment's ETC is manually changed, the task dates change to only cover the period the assignment has ETCs. Changing tasks to Fixed Duration and Loading Pattern for the Assignment to Fixed can help in keeping task dates as expected.
  • If the task assignment has ETC, posting timesheets affects the task dates. Even if the timesheet that is posted does not contain any entries for the task, this issue can occur.
  • Updating ETCs in the Flyout Task Details in the Modern UX moves both the start and the end date of the Assignment, and subsequently moves the task Start and End Date as well. In Modern UX, use the 'Grand Total' setting, instead of 'Sum of Periods'.
  • If time is posted against the task on a date that is prior to the current task Start date, the start date will then change to that earlier date. You won't be able to change the finish date to a date earlier than the actual thru date.
  • For effort tasks, pushing out a task Finish Date may increase the total ETC hours on each assignment. For all other tasks, the total ETC hours on each assignment will remain the same, but the ETC hours will automatically redistribute uniformly across the new task duration.
  • Clarity defaults the assignment start/finish date to the project date, if you add segments with specific dates and ETC, then Clarity will take the earliest date of ETC as the start date and the latest as the finish date. If you need the assignment dates to not change, there will have to be ETCs assigned across those dates, not just one month.
  • When there is ZERO ETC on the assignment, the Finish Date on the assignment goes up to the actuals thru date. The only way to add more ETC on this type of assignment is to update the assignment directly.
  • With fixed loading pattern, once actuals get posted, the Actual Thru date gets updated on the task assignment, and any remaining ETC hours previous to this date will be zeroed out.