Integration between SDM and Jasper stopped working after renewing SSL certificate and getting error "AHD04405: CA service Desk Manager System Internal error".
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Integration between SDM and Jasper stopped working after renewing SSL certificate and getting error "AHD04405: CA service Desk Manager System Internal error".

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Article ID: 391397

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After updating the SSL certificate, getting error "AHD04405: CA service Desk Manager System Internal error" when clicking Insights within the SDM GUI.
 
In the stdlog, the message is seen:
Problem creating Jasper Profile. Error: Exception occurred while creating user
 
In the jstd.log we can see:
ERROR SDMJasperUserSync 362 ERROR INSIDE SDMUserSync = javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target.

 

As per the JasperServer.log noted :

WARN KeystoreManager(Initialization),main:54 - Current system user can't modify keystore

Environment

Service Desk Manager 17.4

Cause

The certificate import was performed via Keystore.

Resolution

It is recommended to import via pdm_perl.  After exporting the certificate from the browser (for instance jasper_ssl.cer) and importing it into NX.keystore using pdm_perl.exe as below:

NX_ROOT\bin>pdm_perl.exe pdm_keystore_mgr.pl -import jasper_ssl.cer