Post upgrade to DSM 2.2.1, LDAP username appears briefly and then disappears from the login screen.
search cancel

Post upgrade to DSM 2.2.1, LDAP username appears briefly and then disappears from the login screen.

book

Article ID: 391394

calendar_today

Updated On:

Products

VMware Data Services Manager

Issue/Introduction

 After upgrading to DSM 2.2.1, when trying to log in, a LDAP user shows briefly, and then disappears.

Environment

VMware Data Services Manager 2.2.1

Cause

In DSM 2.2.1 VMware made a change to the authentication process that eliminated the need for storing LDAP users locally.

Provider now fetches the subject directly from the LDAP server using the "login attribute".

In cases where field value in Directory Service configuration for 'Search User Attribute' contains a leading or trailing space(s) it may lead to the login issue described.

Resolution

Work around: Remove any leading/trailing spaces in account's configuration on Directory Service side and try again.

Additional Information

This will be fixed in a future release of DSM