Agent crashes opening the Report of a running job containing very long lines
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Agent crashes opening the Report of a running job containing very long lines

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Article ID: 391266

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When a Job is still running AWI retrieves the Job Report directly from the Agent.

The Agent crashes if such a Report contains a line with thousands of characters.

The last line of the Agent log looks like this:

U02000256 Upload of file '<path_to_agent>/bin/../temp/OAxxxxxx.TXT' started. 

Up to 5000 characters in one line is still OK, but 10.000 or more characters will cause the Agent to crash.

Once the job has finished and the Report is also available in the database there is no problem.

Cause

This is a limitation of c-based (classic) Agents

Resolution

Replace the c-based Agent with a Java-based Agent

Additional Information

This was tested to work on a v21.0.13 Java Agent or v24.3.0 Agent