Aria Automation remote console disconnected after some time
search cancel

Aria Automation remote console disconnected after some time

book

Article ID: 391240

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

  • the remote console was opened for some time but then shows the pop-up: "'The console has been disconnected. Close this window and re-launch the console to reconnect."
  • the remote console can then no longer be used
  • the time for the pop-up to appear can vary, there is no common factor identified
  • the disconnect does occur after the VM has been idling and the VM screen is turned off by the Guest Operating System

Environment

Aria Automation 8.x

Cause

The Remote Console connection disconnected, which can be due to different factors such as Network connectivity, session idleness or a possible VM migration (vMotion) occurring.

To better understand the possible reason for the disconnect you can review the logs of Aria Automation and the ESXi where the VM resides during the time of the issue.

Resolution

If the connection was disconnected because the Guest Operating System turned off the display then please increase or disable the timeout. By default Windows does Turn off the display after 10 Minutes.

If this does not resolve the issue, to investigate it please try to identify any common factors or eliminate possible obstacles. 

  1. Test the connectivity using different Browsers
  2. Does connectivity behave different while connected from the same Network instead of using a VPN or similar routed connection?
  3. Is the behaviour occurring more often to specific VM Guest Operating Systems, Guest configured screen resolution?

To review logs in Aria Automation, please review logs of the provisioning-service-app located here: /services-logs/prelude/provisioning-service-app/file-logs/provisioning-service-app.log if using a cluster the currently used Appliance can vary and therefor logs of each appliance will have to be reviewed. Alternatively to live tail the logs from each cluster node use this command: 

vracli logs --service provisioning-service-app -f

 

If you see the following error Max frame length of 262144 has been exceeded then the frame size can be increased, below a sample log:

<TIMESTAMP> ERROR provisioning [host='provisioning-service-app-1234567890-12345' thread='reactor-http-epoll-01' user='' org='' trace='' parent='' span=''] c.v.w.p.s.c.WebSocketClientToVCenterHost.lambda$handle$0:47 - [vRA host: AriaAutomation.example.com communicating with vCenter Host: wss://ESXi.example.com:443/ticket/12345678901234567890123456789012]: Failure receiving message from VC host
        io.netty.handler.codec.http.websocketx.CorruptedWebSocketFrameException: Max frame length of 262144 has been exceeded.
                at io.netty.handler.codec.http.websocketx.WebSocket08FrameDecoder.protocolViolation(WebSocket08FrameDecoder.java:427) ~[netty-codec-http-4.1.110.Final.jar:4.1.110.Final] 

To increase frame size:

  1. Login to Aria Automation
  2. Use the below URL to access the hidden configuration properties page:
    https://VRA_FQDN/automation/#/service/automation-ui/provisioning-ui;ash=%2FconfigurationProperties
  3. Configure the property remote.console.proxy.max.frame.payload.length.bytes to set it to 512000 (the default is 262144 bytes). If the property is not available then define it.