"WARN com.aprisma.errorlog - Unable to obtain user attributes" appearing in Spectrum OneClick log
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"WARN com.aprisma.errorlog - Unable to obtain user attributes" appearing in Spectrum OneClick log

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Article ID: 391223

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

What do the following warning messages in the Spectrum OneClick server log ($SPECROOT/tomcat/logs/catalina.out or stdout.log in Windows) indicate:

2025-03-12 22:37:16,437 [http-nio-8080-exec-5] WARN  com.aprisma.errorlog - Unable to obtain user attributes

Environment

DX NetOps Spectrum all currently supported releases

Cause

These log messages come from Security SPSSORB functionality where the given user model is checked if it’s a SuperUser or not (so as to assign permissions).

For the given usermodel, the code tries to fetch the user attributes from the Landscape to identify if this user is a SuperUser or not.

When the checking code fails and errors out, then Spectrum prints out the log statement:

WARN  com.aprisma.errorlog - Unable to obtain user attributes

 

Resolution

Make sure that the OneClick server is connected to all the Landscapes as this will happen if one of them is down and a user is logging in where their user model is located on that landscape.