New Disk showing as ineligible while adding to a vSAN disk group
search cancel

New Disk showing as ineligible while adding to a vSAN disk group

book

Article ID: 391222

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • Unable to claim new disks added to the vSAN host by the existing vSAN disk group.
  • Disk showing as ineligible to claim by vSAN in vSAN cluster >> Configure >> Disk Management and even after erasing partition and reinserting the disk the issue still persists.

 

  • In the vCenter Server UI, under host reporting, one disk is marked as ineligible. When selecting the disk under Storage Devices in configure tab, no old partition details are shown, and the section appears blank.

 

 

Environment

VMware vSAN 7.x
VMware vSAN 8.x

Cause

Due to an already existing GPT partition which is in a faulted state vSAN is unable to claim the disk as part of the new disk group.

A new disk should not have any partitions if it does contain partitions then the disk won't be eligible for use by vSAN.

 

Resolution

To resolve this issue, follow these steps:

1) Check the disk for the current partition details:

# partedUtil getptbl "/vmfs/devices/disks/naa.####################
Error: Both the primary and backup GPT tables are corrupt.  Try making a fresh table and using Parted's rescue feature to recover partitions.
Unable to read partition table for device /vmfs/devices/disks/naa.##################

2) Need to create a new MS-DOS partition on the affected disk(s). This would Overwrite the faulted GPT table with msdos:

# partedUtil mklabel /dev/disks/naa.####################  msdos

NOTE: This will ERASE ALL DATA on the disk in question so be careful to select the right disks!

3) Confirm the GPT label has changed to MSDOS:

# partedUtil getptbl "/vmfs/devices/disks/naa.####################
msdos
291841 255 63 4688430768

4) Now the disk can be claimed via vCenter to be added to the disk group.