How to clean up IM-SiteMinder objects
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How to clean up IM-SiteMinder objects

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Article ID: 391191

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Updated On:

Products

CA Identity Manager

Issue/Introduction

IM - Siteminder integration creates objects in Policy Store. When it is necessary to reconfigure the integration, before redoing the import, the Policy Store created objects need to be cleaned.

Environment

Identity Manager 14.5

SiteMinder 12.8

Cause

Unsuccessful IM - SiteMinder integration.

Resolution

Follow the steps below:

    - Using SSO AdminUI delete the created "userstore" directory under User Directory node and also delete created SQL Query Schemes under that node.
    
   


    
   


    - Using XPSExplorer go to 136 - IMSDirectory (the number may be different if Siteminder version is different), enter 's' to search, enter '1' then 'd' to delete.  To make sure it is deleted enter 'q' 2 times to go to main menu, select 136 again and 's' for search. You should see "There are 0 objects in the result"

 
    - Using XPSExplorer go to 137 - IMSEnvironment, and do similarly as above
    - Quit XPSExplorer and re-run it again and re-confirm it is clean
    - Quit XPSExplorer at the end

Make sure to quit XPSExplorer before retrying to re-integrate/restart IM/reimport directory.