Error Incompatible device backing specified for device '0' when trying to add an RDM to a VM that resides on vSAN or vVOl
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Error Incompatible device backing specified for device '0' when trying to add an RDM to a VM that resides on vSAN or vVOl

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Article ID: 391143

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Updated On:

Products

VMware vSAN VMware vSphere ESXi

Issue/Introduction

  • VM resides on vSAN or vVol
  • When trying to add an RDM to the VM it fails with error "Incompatible device backing specified for device '0'."
  • In /var/run/log/hostd.log you see below:
    [YYYY-MM-DDTHH:MM:SS] error hostd[2101830] [Originator@6876 sub=Vdisksvc opID=lq7e4eth-#######-auto-1kg1m-h5:70887696-4-01-19-fef2 user=vpxuser:ORA-ITMCLOUD.NTTDATA.LOCAL\Administrator] ValidateDiskDevice: Invalid datastore vsan:5245c7451fb9cf7d-b7d5############ specified.
    [YYYY-MM-DDTHH:MM:SS] info hostd[2101830] [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/vsan:5245c7451fb9cf7d-b7d5############/6332b067-3651-5abd-9ad1-############/VM-Test.vmx opID=lq7e4eth-#######-auto-1kg1m-h5:70887696-4-01-19-fef2 user=vpxuser:ORA-ITMCLOUD.NTTDATA.LOCAL\Administrator] ValidateRawDiskDevice: Rdm device is not supported
    Note: 
    You will see similar messages regarding vVols as well

 

Environment

VMware vSAN (All Versions)

vSphere ESXi (All Versions)

Cause

RDMs are not supported for VMs that reside on vSAN or vVols

Limitations of vSAN

Virtual Volumes Limitations

Resolution

  • If an RDM is required for use with the VM, migrate the VM to a VMFS datastore if possible.
  • If the VM can't be migrated to a VMFS datastore, you will need to use a VMDK.