ESXi fails to boot with a purple security screen following a BIOS time/date reset
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ESXi fails to boot with a purple security screen following a BIOS time/date reset

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Article ID: 391082

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article will assist when troubleshooting the failure of an ESXi host to boot after date or time reset at hardware level within the BIOS/EFI firmware.

Error Message:

The issue is observed even if Secure Boot is set to true, with TPM enabled, and execInstalledOnly=TRUE, as shown below. Refer to Enable or Disable the Secure Boot Enforcement for a Secure ESXi Configuration.

Environment

VMware vSphere ESXi 7.0.x

VMware vSphere ESXi 8.0.x

Cause

This issue can occur when the BIOS (CMOS) battery of the host is expired and no longer holds a charge, causing the BIOS settings to be non-persistent, resulting in date and time being reset to the default values after a hardware reset/reboot, as can be seen in the screenshot below.



This can also happen when the BIOS is manually reset.

 

Resolution

  • To resolve this issue, please correct the System Date and System Time to the correct, current date and time.
  • The time should be set to UTC. Please do not use local time.
  • If there is an option to select a time zone, please select UTC for this as well.
  • Then, boot the host.

If the issue persists despite the BIOS date and time being correct, please refer to https://knowledge.broadcom.com/external/article/312109/esxi-boot-failures-due-to-system-configu.html.