An unhandled exception occurs when changing database settings on the Configure Settings page
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An unhandled exception occurs when changing database settings on the Configure Settings page

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Article ID: 391054

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

When trying to change the database server following the steps in Moving an existing CMDB from one SQL server to a new SQL server you may be presented with the following error: 

Unhandled exception has occurred in your application.  Cannot add self node into collection of children. 

The product shown in the error may be a very old version of a solution that you no longer have installed:

Environment

ITMS 8.7.x

Cause

Installing point solutions, such as Altiris Inventory Solution, Altiris Software Management Solution, or platform instead of using the suites option in Symantec Installation Manager.

The problem in code that generates supersedes to fix PL problems. For example, it adds a supersede for a product that is already set as a "dependency". 

Resolution

This issue has been fixed in our ITMS 8.8 release.

If you need assistance fixing this issue on prior versions, please reach out to Broadcom Support.