Identity Manager WebSphere install or upgrade does not complete
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Identity Manager WebSphere install or upgrade does not complete

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Article ID: 391020

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Updated On:

Products

CA Identity Manager

Issue/Introduction

The IDM installer may run briefly and show completed successfully, but the installation logs do not get updated with the latest, expected version.

There are no folders in the Identity Manager deployed location showing new times stamps or updated logs even though the screen indicates the following.

===============================================================================
Installing...
-------------

 

[==================|==================|==================|==================]
[------------------|------------------|------------------|------------------]

 

 

===============================================================================
Upgrade Complete
----------------

Environment

Identity Manager for WebSphere Application Server.

 

Cause

Possible causes are;

1. Failure to run the IM installer as the ROOT user.

2. Failure to copy all the installation files from the installer distribution.

     For example, these are the folders/files that should be part of the IM installer, but several may be missing if not unzipped or copied properly.

CADirectory_x64
ca-im-14.5.0-linux.bin
Framework
 imlayout.properties
 license.txt
MultiDBInstaller
 PasswordTool
 Provisioning

Resolution

1. Be sure to run the installer as ROOT.

2. Copy the full, downloaded installer package and unzip/uncompress its contents on the WAS deployment manager node. Do not copy individual install files or folders to the WAS server, as the entire distribution must be present for the installation to run successfully.