PPM does not allow usernames with forward slash when integrated with AD/ldap

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Article ID: 39102

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Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM On Premise

Issue/Introduction

Issue: 

PPM does not allow usernames with forward slash when integrated with AD/LDAP

When using a forward slash in the Common Name (CN), an error is seen on logging in, similar to this:

ERROR 2015-12-23 10:45:44,921 [http-bio-7172-exec-1] directory.LDAPDirectoryService (clarity:unknown:none:security.loginAction)
Authentication exception for::"cn=<lastname>\, <firstname> / <companyname>,ou=Users,ou=,ou=,ou=Client,dc=,DC=win,DC=,DC=:: 
due to this reason::[LDAP: error code 34 - Incorrect DN given

Cause: 

Caused by CLRT-79642  

Resolution: 

Resolved in CA PPM 14.3 Generic Patch #5  

Additional Information:  

Reference TEC1696455 : PPM 14.3 Generic Patch available to resolve reported issues  

Environment

Release: ESPCLA99000-14.2-Clarity-Extended Support Plus
Component: