The message "Failed to refresh gateway MAC, vmknic [vmk10] : Status pending" keeps appearing in the vmkernel log
search cancel

The message "Failed to refresh gateway MAC, vmknic [vmk10] : Status pending" keeps appearing in the vmkernel log

book

Article ID: 390975

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Following log lines keep appearing in the vmkernel log file regarding TEP vmk interfaces (vmk10, vmk11):
2025-01-28T05:15:58.817Z cpu0:209####)WARNING: vdl2: VDL2IFMVMKGatewayMACResolveCB:2794: [nsx@6876 comp="nsx-esx" subcomp="vdl2-1833####"]Failed to refresh gateway MAC, vmknic [vmk10] : Status pending
2025-01-28T05:16:08.817Z cpu1:209####)WARNING: vdl2: VDL2IFMVMKGatewayMACResolveCB:2794: [nsx@6876 comp="nsx-esx" subcomp="vdl2-1833####"]Failed to refresh gateway MAC, vmknic [vmk10] : Status pending
  • ESXi host has NSX installed.
  • The IP pool for the TEP has a Gateway configured.

Environment

VMware NSX

Cause

This message occurs when the MAC address of the IP address set as the Gateway for the TEP IP pool can not be resolved.

Resolution

  • Review the underlay network configuration so that the Gateway MAC address can be resolved.
  • Confirm that the correct gateway has been configured on the transport node using the command 'net-vdl2 -l' on the host:
[root@<hostname>:~] net-vdl2 -l
Global States:
        Control Plane Out-Of-Sync:      No
        VXLAN UDP Port: 4789
        Geneve UDP Port:        6081
NSX VDS:        <VDS Name>
        VDS ID: <ID>
        MTU:    8900
        Segment ID:     <ID>
        AddrType6:      Not Configured
        Segment ID6:    ::
        Transport VLAN ID:      <VLAN ID>
        VTEP Count:     2
        Forwarding Mode:        IPv4_ONLY
        CDO status:     enabled (deactivated)
                VTEP Interface: vmk10
                        DVPort ID:      <ID>
                        Switch Port ID: <PORT ID>
                        Endpoint ID:    0
                        VLAN ID:        <VLAN ID>
                        Label:          <VNI ID>
                        Uplink Port ID: <UPLINK PORT ID>
                        Is Uplink Port LAG:     No
                        IP:             <VTEP IP ADDRESS>
                        Netmask:        255.255.255.0
                        Segment ID:     <SEGMENT ID>
                        IPv6:           ::
                        Prefix Length:  0
                        Segment ID6:    ::
                        GW IP:          <VTEP GW IP ADDRESS>
                        GW MAC:      <VTEP GW MAC ADDRESS>
  • If an incorrect Gateway IP is configured, then check that the host is configured with the correct TEP IP pool or that the pool is correctly configured. If a DHCP server is being used for IP address assignment on the TEP interfaces, then check its configuration.
  • If the network configuration does not require resolving the Gateway's MAC address, remove the Gateway from the TEP IP Pool configuration.

Additional Information

In network configurations where overlay communication does not need to pass through any Gateway router, such as, when all TEPs are in the same network segment, inability to resolve the gateway MAC does not impact overlay communication.