After installation of CABI 6.1 JasperServer Reports a license check fails
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Article ID: 39079
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Updated On:
Products
CA Spectrum
Issue/Introduction
After successful installation an error about the license is received when attempting to access the JasperServer URL.
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Environment
Windows 2008 Windows 2012
Cause
The jasperserver.license entry is not in the java parameters for Tomcat.
Resolution
Add the license directory java parameters for Tomcat: 1. Go to the Jasper Reports Server 2. Go into the Tomcat Installation bin directory (I.e. C:\Tomcat8\bin) 3. Execute Tomcat8w.exe 4. Add the license parameter to the Java tab: -Djs.license.directory=<tomcat_home>/webapps/jasperserver-pro
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5. Click Apply and OK 6. Restart Jasper Tomcat
Additional Information
Workaround: If for some reason you cannot make the suggested modification above or it fails, you can try placing the jasperserver.license file in the following location instead of the folder mentioned in the product documentation: C:\Windows\System32\config\systemprofile