Unable to open HCX UI on port 9443 using browser - unbale to login via web console
search cancel

Unable to open HCX UI on port 9443 using browser - unbale to login via web console

book

Article ID: 390774

calendar_today

Updated On: 06-11-2025

Products

VMware HCX

Issue/Introduction

  • When opening HCX Management UI on port 9443 you encounter the following error:
    https://<FQDN>:9443/
    error:-"ERR_CONNECTION_RESET".
  • Access to HCX UI on port 443 is working as expected.
  • Telnet is working fine to HCX Manager on port 9443. 
  • Running tcpdump in HCX Manager when trying to open HCX Management UI on port 9443 you see that after TCP handshake there is RESET ACK ( [R.] ) packet received which breaks the connection. 
    1. Login to HCX Manager over SSH as admin.
    2. Run the following command (ctrl+c to stop the capture):  # tcpdump tcp port 9443 -ne
    3. Try to open HCX Management UI:  https://<FQDN>:9443/
    4. You see the packets being exchanged with the following flags:  

Cause

Most likely there is a firewall which is blocking the SSL connection to HCX Manager when trying to open HCX Management UI on port 9443.

Resolution

You can do a trace route from the client machine to HCX Manager to get the list of devices in the datapath. (Routers/Gateways) 
One or more of the devices will be a firewall.
Engage with your firewall team to investigate why the connection is being blocked.

Additional Information

Note: HCX Manager running "Admin" services over TCP port 9443 (SSL/TLS) may get flagged for older cipher and will be discovered by modern security scanning tools like Qualys.

HCX - SSL/TLS services running on TCP port 9443 flagged for DH 1024 key-size