Error: "Failed to connect to the server" after upgrading VMware Cloud Director
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Error: "Failed to connect to the server" after upgrading VMware Cloud Director

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Article ID: 390746

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Attempting to log into the VMware Cloud Director (VCD) Service Provider Admin or Tenant Portals fails with the error message:

    org.apache.tomcat.jdbc.pool.PoolExhaustedException: [pool-jetty-1378842] Timeout: Pool empty. Unable to fetch a connection in 20 seconds, none available[size:200; busy:200; idle:0; lastwait:20000]

  • Attempting to log into VMware Cloud Director succeeds, but the closes after login, kicking the user out with the error message:

    HTTP ERROR 404 JSP file [/error.jsp] not found

  • There are intermittent connectivity issues to the VMware Cloud Director cells.

Environment

 

VMware Cloud Director 10.5.1

Cause

This issue occurs when the system value for the database pool has been manually overwritten by a user in the /opt/vmware/vcloud-director/etc/global.properties file

Resolution

To resolve this issue you need to remove an entry from the global.properties file. Please, follow the below steps to resolve the issue:

  1. ssh to Primary cell of the VCD infrastructure.
  2. Login as root user.
  3. Go to the directory:

    /opt/vmware/vcloud-director/etc

  4. Now edit the global.properties using the below command:

    vi global.properties

  5. Remove the value of database.pool.maxActive which is shown below. Remove any other database.pool entries if present in the file.

    database.pool.maxActive = 200

  6. Now save the global.properties file using the command:

    wq!

  7. After the changes are made to the file, restart the VCD services on all the cells using the below command:

    systemctl resart vmware-vcd.service

Note: If you are seeing pool exhaustion issues when using the default please follow this document: https://knowledge.broadcom.com/external/article?articleId=376122