EDM profiles are not created on the Enforce
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EDM profiles are not created on the Enforce

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Article ID: 390730

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Network Discover

Issue/Introduction

You see that none detection servers have this profile, errors like "Data file cound not be read" etc. At the same time, you see the below error during the time of indexing in the localhost log file:

06 Mar 2025 01:00:03,970- Thread: 72 SEVERE [com.vontu.profiles.manager.InfoSourceIndexCreator] Indexing failed. Trigger Name: ###_DATA_SOURCE_INDEX_TRIGGER IDs: [I@1e945b2e
Cause:
java.lang.NullPointerExceptionjava.lang.NullPointerException
    at com.vontu.profiles.manager.database.DataSourceIndexCreator.deleteFiles(DataSourceIndexCreator.java:1115)
    at com.vontu.profiles.manager.database.DataSourceIndexCreator.cleanIndexFilesOnFailure(DataSourceIndexCreator.java:1100)
    at com.vontu.profiles.manager.database.DataSourceIndexCreator.doIndex(DataSourceIndexCreator.java:815)
    at com.vontu.profiles.manager.database.DataSourceIndexCreator.indexInfoSourceOnManager(DataSourceIndexCreator.java:189)
    at com.vontu.profiles.manager.InfoSourceIndexCreator.indexListOfDataSources(InfoSourceIndexCreator.java:260)
    at com.vontu.profiles.manager.database.DataSourceIndexJob.index(DataSourceIndexJob.java:43)
    at com.vontu.profiles.manager.InfoSourceIndexJob.execute(InfoSourceIndexJob.java:80)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:213)
    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557)

Environment

15.8

16.0

Cause

There is an issue with accessing C:\ProgramData\Symantec\DataLossPrevention\ServerPlatformCommon\VERSION\index folder to create profile files.

Resolution

Make sure that DLP service account has permission to index folder

or

rename the current folder to index_bak and create a new index folder.