VCHA failover occurs unexpectedly and logs indicate no reason
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VCHA failover occurs unexpectedly and logs indicate no reason

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Article ID: 390707

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

VCHA failover occurs unexpectedly and logs indicate no reason

Environment

  • VMware vSphere 8.x 
  • VMware vSphere 7.x 

Cause

You see a vCenter High Availability primary node fail over without any errors 

 
When issues with the main thread or a system failure cause a failover of a vCenter High Availability primary node, the system restarts, but you might see no errors in the vCenter Service Life Cycle Management logs. The issue occurs because of a
LINUX_REBOOT_CMD_RESTART
call immediately after the restart without a sync, which prevents the proper logging of error messages. As a result, you see no errors after the restart and the vCenter High Availability primary node failover seems unexpected.
 
 
The logs will not providing any information about the reboot where the reboot is triggered within the Guest OS. An enhancement is included in the later versions of the vCenter build that will write down the logs about the cause of the Guest OS reboot. Having said that, this enhancement will not address the issue of an unexpected reboot of the vCenter. However, it will make sure the logs are created for any such reboot incidents which will help us root causing the unexpected reboots.
 

Resolution

This issue is resolved in vCenter Server 7.0 Update 3q Build 23788036. The fix makes sure that vCenter Service Life Cycle Management logs the error messages properly after a vCenter High Availability primary node restart from a failover.
 
The same bug exist in the vCenter 8.x  releases as well. The latest vCenter Server 8.0 Update 3d Build 2432283 has been incorporated with the above-mentioned fix.