Remove VC logs of more than 60 days to release /storage/log space.
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Remove VC logs of more than 60 days to release /storage/log space.

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Article ID: 390705

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • There could be a error message at VAMI:
    • "File system /storage/log has run out of storage space. Increase the size of disk /storage/log."
  • On the vCenter summary page, you will see an alert.
    • "Log Disk Exhaustion on <vCenter_name>"

After checking no log bundle is left under /storage/log/, the space is still almost full.

To check and remove log bundles for space, see /storage/log becomes 100% full when exporting the vCenter Appliance log bundles.

 

Environment

VMware vCenter 7.0

VMware vCenter 8.0

Cause

The alert is triggered by the vCenter alarm configuration, which is set to activate when the usage of any disk exceeds 80%.

Resolution

  1. Verify the space status of /storage/log directory.
    df -h
  2. Change directory to /storage/log.
    cd /storage/log
  3. Find all log files longer than 60 days. Verify that there's no useful one.
    find  ./ -type f  -mtime +60 -exec ls -l {} \; | cut -d " " -f 6-15
  4. Remove all log files longer than 60 days.
    find  ./ -type f  -mtime +60 -exec rm {} \;
  5. Verify they are removed by repeating step 3.
  6. Verify space is released by repeating step 1.