CNS volumes may be removed from the cache following a VSAN partition in vCenter 8.0.3.
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Article ID: 390695
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Updated On:
Products
VMware vSphere ESX 8.xVMware vSphere ESXi
Issue/Introduction
In the context of this issue, the volume is removed from the cache while still stored in other areas.
Environment consistently seeing errors like "NotFound", "AlreadyExists", or "NotRegistered" on a volume that was previously working correctly, it's likely this issue.
Environment
vSphere 8.0 Update 3 and vSphere 8.0p04.
Cause
CNS volumes getting removed from the cache is not necessarily an error. However, in the context of this issue, the volume is removed from the cache while still stored in other areas.
When CNS queries volumes during a vSAN partition it will fail with a NotFound error, and CNS will remove the volumes from the cache.
Resolution
The issue is fixed in vSphere 8.0 P05
Workaround :
Run a CNS full Sync by going to https://<vCenter-IP address>/vslm/mob/?moid=StorageLifecycleManager&method=VslmSyncDatastore.
The datastoreUrl field should not be left blank, and can be taken from the VC UI, fullSync field should be set to true, and everything in the fcdId field should be deleted.
The message "SyncDatastoreTask started." in /var/log/vmware/vsan-health/vsanvcmgmtd.log will confirm that the sync has started.