Manually clean up of Duplicate or Stale entries of VR/SRM in vCenter server.
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Manually clean up of Duplicate or Stale entries of VR/SRM in vCenter server.
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Article ID: 390686
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Updated On: 03-12-2025
Products
VMware Live Recovery
Issue/Introduction
Symptoms:
VDT Tool reports Duplicate entries to unregister,
LS Doctor shows duplicate endpoint to unregister,
2025-03-10T22:32:34 ERROR generateReport: default-first-site\XXXXXXXXXXX.XXXXX.CCCC (vSphere Replication) found Duplicates Found: Ignore if this is the PSC HA VIP. Otherwise, you must unregister the extra endpoints.
Note: The same issue may appear with SRM, please follow the same steps.
Environment
vCenter Server 7.x
VMware vSphere Replication 9.0.2
VMware Live Recovery 9.0.2
Cause
Duplicate or stale entries are the results of improper decommission of external PSC, or Change from ELM to standalone.
Incorrect Configuration during deployment of SRM/VR causes stales.
Resolution
If the above symptoms matches, please raise case with Broadcom Support to investigate the issue.
Additional Information
Important Note:
If the VC are in linked mode please capture offline snapshots.
Please perform the same steps on other VC in pair to remove stale entries.
The username used for the above commands needs to have administrator privileges.
Below steps to be performed to manually delete vSphere Replication stale entries.
Command to capture all the services and registrations on the vCenter Server.
/usr/lib/vmware-lookupsvc/tools/lstool.py list --url http://localhost:7090/lookupservice/sdk > /tmp/servicelist.txt(file name)
Open The file in read mode and using the keyword search for Service registrations,
less /tmp/servicelist.txt
Use keyword - vrUi, vcHms, VMware Site Recovery, vcDr, h5-dr. validate for old versions,