Symptoms:
EEM safex-error such as 'ETPKI home is not set'?
The message appears when running the EEM safex command.
Environment:
CA Service Catalog and EEM on a Windows platform.
Cause:
The following is explained in the Readme.pdf file for patch RO86785_Incr_SC_14.1.02
NOTE:
In case if you face an error while running the SAFEX command such as 'ETPKI home is not set', then follow the steps below.
Root cause:
The most likely root cause of this error being, CA EEM being installed on a different machine than Catalog server.
Resolution/Workaround:
The post install step as shown earlier:
18. Post installation steps:
Open(e.g. with notepad)
%USM_HOME%\view\scripts\EIAM\Safex\usm_create_additional_application_data.xml
and update the label value (__EIAMAPPNAME__)
of the Attach XML tag with actual EEM application name.
The actual EEM application name can be found in
%USM_HOME%\config.proper (i.e. the value Service Catalog)
>> Example:
>> ###############################################################
>> # EEM related configuration
>> ###############################################################
>> eem.configured = true
>> # Mandatory parameters for command line interface
>> eiam.application = Service Catalog
The steps to follow:
1. Perform step 18 from above
2. Copy the file usm_create_additional_application_data.xml to the EEM Server machine and place it in a folder.
Write down the 'path' of this folder to be used in step 5.
3. Open the Command prompt
4. Go to the EEM installed folder path e.g.:
C:\Program Files\CA\SC\EmbeddedEntitlementsManager\bin
5. Run the following command
safex -h <EEM_HOST> -u EiamAdmin –p <EEM_ADMIN_PASSWORD> -f <path_from_step2>\usm_create_additional_application_data.xml
6. Then you can login to the EEM UI choosing the 'Service Catalog' application name and click on Configure > Session > Synchronize Cache