Cannot authenticate using vCenter root credentials when logging into the VAMI
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Cannot authenticate using vCenter root credentials when logging into the VAMI

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Article ID: 390646

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

This issue can occur with the following symptoms: 

  • Authentication fails when logging into the VMware Appliance Management Interface (VAMI) using root credentials, but the root credentials do work via SSH. 
  • The following error messages can be received when attempting to login to the VMware Appliance Management Interface (VAMI) using root credentials:

    Unable to authenticate user

    "[ERROR]: Failed to connect to service.
    Use service-control command to manage applmgmt service"

Environment

7.x
8.x

Cause

This issue is caused by the appliance management service not functioning as intended or if the service is not running. 

Resolution

To resolve this issue, please see the steps below. 

  1. SSH into the vCenter Server
  2. Run the following command (if not already in the BASH shell):

    shell

  3. Check the status of the appliance management service:

    service-control --status applmgmt

    1. If the service is not running, start the service manually:

      service-control --start applmgmt

    2. If the service is running, attempt to restart the service:

      service-control --stop applmgmt && service-control --start applmgmt

  4. Confirm the service is running after attempting the manual start and/or restart:

    service-control --status applmgmt

  5. Attempt to authenticate to the VMware Appliance Management Interface (VAMI) using your root credentials. 

If the service fails to start, please gather a log bundle from the vCenter Server and contact Broadcom support.