Failed to check AD RID Pool Free due to error: not null
search cancel

Failed to check AD RID Pool Free due to error: not null

book

Article ID: 390589

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We are monitoring our AD Server with ad_server probe, and we get the following error from the AD RID Pool monitor. 

Failed to check AD RID Pool Free due to error: not null

Why is this happening? 

Environment

  • DX UIM 23.4.*
  • ad_server 2.0*

 

Cause

 The probe may not have access to the AD system / RID Pool Master. 

Resolution

The behavior is expected if the ad_server probe is deployed on a AD Server that is not a RID master machine.

The ad_server can only generate effective QOS_RIDPOOLFREEPERCENT qos if it can contact the RID Master node.

For non RID Master nodes, deactivate the AD Rip Pool objective monitor