RDP connection hangs while trying to enter a user/password in windows task scheduler.
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RDP connection hangs while trying to enter a user/password in windows task scheduler.

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Article ID: 390515

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Updated On: 03-12-2025

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When using the PAM RDP client and saving a Windows Task Scheduler item that requires credential entry, the process hangs and Task Scheduler goes to "not responding"  The task will only complete if you exit and reconnect the RDP session.

Using the same account this does not occur when:

  • Using the native Windows RDP client via a TCP/UDP service via PAM
  • Using the native Windows RDP client when connecting directly

Is there something different about the connection method used by the PAM RDP client that causes the hang on save?

Cause

In this case the cause was enabling the Windows Hello security service. The Windows service detects the possibility of entering a user/password via the windows hello service and waits until the authentication request times out.

Resolution

The current workaround is to disable this service on the remote server as it was not a required service. Future releases of CA PAM will handle this service.