Issue:
Upgrade from UIM 8.1 to UIM 8.4 is stuck at 35% "Configuring Data Engine Probe ... "
I'm upgrading UIM 8.1 to 8.4 and install get stuck while trying to configure the data_engine probe:.
<Please see attached file for image>
The uimserver_ia_install.log reports the below Exception:
[…]
DEBUG probe.AdeController:distributePackageSynchronous:114 [Thread-43] - Sending getPackageDistributionStatus.
DEBUG pds.PDSController:sendPDSWithAddr:132 [Thread-43] - Sending 'get_status' with sid: EM..., timeout: 120000
ERROR impl.UIMServerConfigureController:run:456 [Thread-43] - NimException caught
(80) Session error, Unable to open a client session for xx.xx.xx.xx:xxxx Connection refused: connect at com.nimsoft.nimbus.NimNamedClientSession.<init>(NimNamedClientSession.java:37)
at com.nimsoft.nimbus.NimObjectSender.connectNamed(NimObjectSender.java:78)
[…]
(this error continues in loop)
Environment:
CA UIM 8.1 upgrade to CA UIM 8.4
Windows 2008 r2
MS SQL DB 2008 r2
Cause:
The errors in the log point to an issue with the automated_deployment_engine which is giving an error in a loop in the install log.
Resolution
To resolve this issue follow these steps:
First cancel the current upgrade attempt.
1. Make sure that the Nimsoft Service is ON in the Primary Hub
2. Deactivate automated_deployment_engine.
3. Go into /Nimsoft/probes/service/automated_deployment_engine/
4. Backup this folder to your desktop before continuing!
5. Delete the database files (automated_deployment_engine.h2, automated_deployment_engine.lock)
6. Delete all files IN ade_package_temp AND ade_xml_temp folders.
7. Activate ADE.
Now re-run the install and the install will complete successfully
Additional Information:
Upgrading & Release Notes
https://docops.ca.com/pages/viewpage.action?pageId=289572370