Users cannot navigate back to CA PPM correctly from Jaspersoft reports by clicking on hyperlinks in the report

book

Article ID: 39046

calendar_today

Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM On Premise

Issue/Introduction

Symptoms:

Users cannot navigate back to CA PPM correctly from Jaspersoft reports by clicking on hyperlinks in the report.

Steps to Reproduce:

  1. Login to CSA
  2. Navigate to Server properties, Application page and click on Save
  3. Login to CA PPM application  
  4. Click on Advanced Reporting  
  5. Select the Project Storyboard report  

Expected Result: More Issues link will navigate user back to CA PPM issues for the project / More Risks link will navigate user back to CA PPM risks for the project

Actual Result: User is navigated to CSA login page   

Cause:

Caused by CLRT-78878 

Resolution: 

Resolved in CA PPM 14.3 Generic Patch #5  

Workaround: 

The following workaround is provided ONLY for v14.3 (if you do not have patch #5).  If the issue is reproduced on v14.2, contact CA Technical Support for assistance.

Execute the following from a command prompt on the server for 14.3

admin jaspersoft syncPPMContext -userName superuser -password superuser 

Additional Information:

Reference TEC1696455 : PPM 14.3 Generic Patch available to resolve reported issues

Environment

Release: ESPCLA99000-14.3-Clarity-Extended Support Plus
Component: