Spring Cloud Service Instance Error - "Access to config-server-<DOMAIN> was denied"
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Spring Cloud Service Instance Error - "Access to config-server-<DOMAIN> was denied"

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Article ID: 390456

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Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

After upgrading the service instance, rendering the dashboard returns Access Denied error through Application Manager -> Services -> Manage.

The dashboard URL and the Spring Cloud Service backend app route should be the same. In this case, they were different. Thus, the Access Denied error.

 

 

 

Environment

  • Tanzu Platform for Cloud Foundry
  • Spring Cloud Services for TPCF

 

Cause

The dashboard URL is returned by the SCS broker and stored is the Cloud Controller database when the service instance is upgraded. It's possible that the SCS broker is in a bad state, and returned an invalid dashboard url.

 

 

Resolution

Please follow the steps below to update the dashboard URL

  1. Restart SCS Broker
    • bosh ssh to the SCS vm
    • sudo -i
    • monit restart scs_broker
  2. Run errand upgrade-all-instances
    • cf update-service <MY_INSTANCE> -c '{"upgrade" : true}'. OR
    • run bosh errand upgrade-all-instances
  3. Retest

If issue persist, please contact Broadcom Support.