When upgrading the NetOps Portal, the installer reports that it failed
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When upgrading the NetOps Portal, the installer reports that it failed

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Article ID: 390344

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

The install logs are reporting the Portal upgrade failed due to mysql being unable to start

Cause

The question regarding what user should own the mysql installation was answered incorrectly and this changed the ownership of the <install dir>/MySql/data and <install dir>/MySql/tmp folders which caused MySQL to be unable to start.

Resolution

By default, the owner of the mysql process is a user named mysql.  Unless there is explicit reason for this user to be set as someone else, you should answer the default entry, mysql, to this question.

To recover from this situation, you will need to revert the ownership changes to the <install dir>/MySql/data and <install dir>/MySql/tmp folders which should be mysql:mysql and mysql:root respectively

chown mysql:mysql <install dir>/MySql/data

chown mysql:root <install dir>/MySql/tmp

At this point, rerun the upgrade ensuring the proper user is referenced to ensure success.