AlarmNotifier not sending alarms to ServiceNow
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AlarmNotifier not sending alarms to ServiceNow

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Article ID: 390278

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

AlarmNotifier SetScript is not successfully sending alarms to ServiceNow using curl. The following errors are shown in the NOTIFIER.OUT:

Feb 09 Sun 05:29:07 EST 2025: Alarm Notification from device
Feb 09 Sun 05:29:07 EST 2025: curl: (6) Could not resolve host: snowserver.com

and

Feb 25 Mon 12:30:09 EST 2025: curl: (28) Connection timed out after 10000 milliseconds

Environment

DX NetOps Spectrum all currently supported releases

Cause

The error indicates a problem with Network DNS

Resolution

This is not an issue with Spectrum or its AlarmNotifier component but is a problem with the network, most likely DNS. There is an easy way to confirm this by using curl on the command line to try and access the specified (FQDN) host, in the example above - snowserver.com

So find the curl command in the Notifier SetScript that you're using for the ServiceNow (SNOW) integration. Then run that command on the Command Line (CLI) of the SpectroSERVER under the same user account that runs Spectrum. If it returns the same error, then the issue is with network DNS.

You could also start by pinging the host, using both FQDN (Fully Qualified Domain Name):

ping snowserver.com

And the short hostname (for example):

ping snowserver

Another possibility is to check the ~/etc/hosts file on the SpectroSERVER and ensure that the snowserver hostname is configured properly using theFQDN if that is what is required.