Service Dashboard does not fully load, or is extremely slow to load, and hangs
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Service Dashboard does not fully load, or is extremely slow to load, and hangs

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Article ID: 390236

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

When accessing the service dashboard, it never fully loads, or is extremely slow to load, and is unusable while using the OneClick WebApp

Service editor in Spectrum seems to be having resources issues.

Our users have created a series of service dashboards that they edit and update on a regular basis. Staring last week, they are no longer able to get the editor to work. When they click on the edit button it takes a minute or more for the tool icons to appear, and they are so slow as to be unusable. Is there a setting that would make this editor quicker?

Environment

Exists as of 24.3.6

Cause

Product defect in webswing code

Resolution

While this will ultimately be resolved in a release after 24.3.6, a temporary workaround does exist at this time:

  1. Login to the webswing admin console page(https://<oneclickHostname>:9443/spectrum) 
  2. Select Applications tab.
  3. Select OneClickWebApp.
  4. Select App Config.
  5. Disable DirectDraw Rendering.
  6. Click on Apply at the right bottom of the screen.
  7. Close the webapp client consoles
  8. Restart webtomcat.
  9. Launch webapp client and validate.

Additional Information

Monitor the Resolved Issues page for DE1672252