Unable to edit LDAP Settings in SDDC Manager
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Unable to edit LDAP Settings in SDDC Manager

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Article ID: 390221

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

We see the following error in the SDDC UI.



A similar error is observed in the vcf-commonsvcs.log

/var/log/vmware/vcf/commonsvcs/vcf-commonsvcs.log

at java.base/java.lang.Thread.run(Thread.java:840)
Caused by: java.lang.NullPointerException: Cannot invoke "String.equals(Object)" because the return value of "com.vmware.vim.sso.admin.Domain.getAlias()" is null

Environment

SDDC Manager 5.2.x

Cause

A known issue where the domainalias is not required when configuring the Identity Source but the edit/update Identity Source workflow requires the value. 

Resolution

The current resolution is to remove the identity source and recreate it with the domainalias value. 

SDDC UI > Administration > Single Sign On > Identity Provider 

1. Record all of the existing configurations.

2. Remove the Identity Provider from the SDDC UI. 

3. Recreate the Identity Provider in the SDDC UI. 

The instructions for configuring AD over LDAP in SDDC Manager can be found here