Problem:
Attempting to install ehealth 6.3.2.11 on Windows server fails at the Database creation stage with the following error:
Even after performing the steps highlighted in TEC1264456 the reinstallation still fails with the same error.
Environment:
eHealth 6.3.2 and above.
Cause:
A previous installation of eHealth (either standalone, distributed or failover) has not been entirely removed. The problem is that there are some Windows registry keys left over from Oracle that need to be deleted. However, not all of these are documented in the Uninstall section (Appendix D) of the eHealth Install Guide.
Workaround:
Manually search for all eHealth and Oracle related keys under:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\
HKEY_LOCAL_MACHINE\SOFTWARE
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
Take a backup and then delete these eHealth and Oracle keys.