Issue with TDM Portal Oracle connection
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Issue with TDM Portal Oracle connection

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Article ID: 390192

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

The oracle connection is working fine in Oracle SQL developer even its working in the datamaker. In portal, it is inconsistent and it fails most of the times.

The connection profile verification in configuration fails intermittently and the data painter query validation for this connection fails all the time.

Error:  The error is <resolve_meta_data_item: TDMServiceException: sqllist: TDMServiceException: Failed to connect: TDMDatabaseException: getDBConnection: Unable to connect to database jdbc:oracle:thin:@//xx.xx.xx.xx:10010/GCEPT;user=DEBUG_USER : Failed to obtain JDBC Connection>

Environment

TDM Portal 4.11.x

Cause

The ojdbc jar is not fully compatible.

Resolution

Follow below steps to upgrade ojdbc driver:

- Stop TDM Portal and OrientDB services.

- Download the ojbdc driver compatible with Oracle 19c ( 19.25.0.0) version. Ref: https://www.oracle.com/pk/database/technologies/appdev/jdbc-downloads.html

- Find the location of existing driver in TDM installation using below command in the command prompt.

dir "%CATDMWEB_HOME%\ojdbc*.jar" /s /b

- Backup a copy of the existing ojdbc JAR file and then replace the ojdbc jar found in all the above locations.

- Clear the logs folder.

- Start the TDM Portal and OrientDB services.