Receive the error 'Cannot authenticate to log provider' when configuring Log ingestion in Cloud Director
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Receive the error 'Cannot authenticate to log provider' when configuring Log ingestion in Cloud Director

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Article ID: 390164

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

When trying to configure the 'Log Ingestion' feature in vCD the error below is received in the vCD UI;

  • Cannot authenticate to log provider 'https://<Operations _for_Logs_FQDN>:9543' - <html><head><title>Servlet Error | Operations for Logs</title> <style> .wolkenCSS .error-page-container{padding:100px 20px 0 20px;font-size:11pt;text-align:center;color:#555;text-shadow:0 1px 0 white).error-page- container h2{font-size:12pt;font-weight:bold;margin-bottom:10px).error-page-message{margin-bottom:10px} </style> </head><body><div class="error-page-container"><h2>Page not found</h2><div class="error-page-message">Sorry, the page you were looking for does not exist</div></div></body></html>

Environment

vCD 10.6.x

Aria Operations for Logs 8.16 and later

Cause

The FQDN used in the 'Service URL' field is incorrect in some way, see the example below;

  • https://<Ops_for_Logs_FQDN>/:9543
  • An extra '/' character has been inserted between the FQDN and port.

 

Resolution

Update the FQDN to the correct one.

When configuring the Log Ingestion feature in vCD you must use the full URL of the endpoint, the port is not necessary.

  • https://<Ops_for_Logs_FQDN>

The port is automatically added after the configuration is successful.

Additional Information

The 'Log Integration' feature can be found on the provider portal in the following menu;

  • Resources
    • Infrastructure Resources
      • Log Ingestion