WAC console does not work after upgrade to CU7 due to JasperException: The Struts dispatcher cannot be found.
search cancel

WAC console does not work after upgrade to CU7 due to JasperException: The Struts dispatcher cannot be found.

book

Article ID: 390096

calendar_today

Updated On:

Products

CA Client Automation CA Client Automation - IT Client Manager CA Client Automation - Patch Manager

Issue/Introduction

The localhost logs report the following error:
 
SEVERE [ajp-nio-0.0.0.0-8020-exec-3] org.apache.catalina.core.StandardHostValve.custom 
Exception Processing ErrorPage[errorCode=500, location=/errors/500.jsp]
org.apache.jasper.JasperException: The Struts dispatcher cannot be found.  This is usually 
caused by using Struts tags without the associated filter. Struts tags are only usable when 
the request has passed through its servlet filter, which initializes the Struts dispatcher needed 
for this tag. - [unknown location]
 
Caused by: The Struts dispatcher cannot be found.  This is usually caused by using Struts tags 
without the associated filter. Struts tags are only usable when the request has passed through 
its servlet filter, which initializes the Struts dispatcher needed for this tag. - [unknown location]

Environment

Client Automation - 14.5 CU6, CU7

Cause

According to the Applyptf logs the CU7 was applied twice, successfully the first time, but failed 
in the second try which should be caused the issue. 

* Replace <DM_HOSTNAME> by the DM hostname

99112083.txt:
===========
Main():applyptf.exe does not exist in . 
Main(): Beginning execution - Mon Feb 03 10:14:09 2025

Main(): Applyptf Wizard:
PTF: 99112083.JCL Node: <DM_HOSTNAME>
Establishing connection to remote node... Please be patient
GetPath(): Path will be '\\<DM_HOSTNAME>\DSM'.
...
ApplyOK(): 
Updating history file
SaveSupersede(): Passed.

Executing SYSCMD  command = runSQLscript.bat
Executing SYSCMDRC  command = PostInstallScript.bat,0
Executing SYSCMDRC  command = helpVerUpdate.bat,0
 
Done.
 
Output File opened

Main():applyptf.exe does not exist in . 
Main(): Beginning execution - Mon Feb 03 10:26:32 2025

Main(): Applyptf Wizard:

PTF: 99112083.JCL Node: <DM_FQDN>
Establishing connection to remote node... Please be patient
...
PTF Wizard has ended the application of this PTF, and suggests that
you call your local CA support representative.


Output File opened

Resolution

In order to solve this problem of installation not completed, reapply the CU7 locally (run the command
from a local directory in the target DM machine) following the steps below adding the INSTALLAGAIN option.

Option /INSTALLAGAIN should be added too to give the possibility to install again the patch if it has already been 
installed.

1. Close DSM explorer if opened.
2. cfsystray stop
3. Change to directory where the CU7 patch is located:

cd \ITCA\ClientAutomation\Patches\CU7\EM_DM_99112083\99112083

4. Execute the ApplyPTF command below:

applyptf.exe  /NODE=<DM_HOSTNAME> /PTF=99112083.jcl /INSTALLNEW /SILENT /INSTALLAGAIN /OUTPUTFILE=99112083.log /DEBUGFILE=99112083.dbg

* Replace <DM_HOSTNAME> by the DM hostname

5. Monitor the ApplyPTF.exe process in the Task Manager -> Detail tab and the 99112083.log with Notepad through the Monitoring icon
until it end showing the line 'Done.'.  The ApplyPTF of CU7 may take > 20 mins to complete.

6. caf status 

7. Review the logs and attach to the case:

99112083.log
99112083.dbg
postInstall.log
preinstall.log
C:\Program Files (x86)\CA\DSM\<DM_HOSTNAME>.his

* Note: It's a rare issue, but in case the Tomcat doesn't start any more check the following procedures:

The files might not existed before the upgrade to CU7:

C:\Program Files (x86)\CA\DSM\Web Console\webapps\wac.war
C:\Program Files (x86)\CA\DSM\Web Console\webapps\AMS.war
C:\Program Files (x86)\CA\DSM\Web Console\webapps\pmengine.war (if using Patch Manager)
 
 
Try the following steps in case of this problem to resolve it:
 
1- Stop tomcat (in case it is started) :
caf stop tomcat
 
2- Copy the needed files wac.war, AMS.war and pmengine.war from CU7 source into 
C:\Program Files (x86)\CA\DSM\Web Console\webapps
 
3- Start tomcat
caf start tomcat
 
4- Wait 5 minutes
Normally following directories should be created :
C:\Program Files (x86)\CA\DSM\Web Console\webapps\wac
C:\Program Files (x86)\CA\DSM\Web Console\webapps\pmengine (if using Patch Manager)
C:\Program Files (x86)\CA\DSM\Web Console\webapps\ams
 
5- Stop tomcat again
caf stop tomcat
 
6- Copy the following files :
C:\Program Files (x86)\CA\DSM\backup\waclog.properties  to C:\Program Files (x86)\CA\DSM\Web Console\webapps\wac\WEB-INF\classes\com\ca\wac\config\
C:\Program Files (x86)\CA\DSM\backup\WACconfig.properties  to C:\Program Files (x86)\CA\DSM\Web Console\webapps\wac\WEB-INF\classes\com\ca\\wac\config\
C:\Program Files (x86)\CA\DSM\backup\AMS.properties  to C:\Program Files (x86)\CA\DSM\Web Console\webapps\AMS\WEB-INF\classes\

7- Start tomcat
caf start tomcat