vSAN Licensing removal option unavailable in vCenter UI
search cancel

vSAN Licensing removal option unavailable in vCenter UI

book

Article ID: 390086

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

The vSphere Administrator is working on removing an unused vSAN license from the vCenter license manager. The administrator has disabled vSAN in the cluster and then moves to the next task to remove the license from the inventory and is confronted with the "remove" option greyed out.

 

Environment

vSAN 7.0x

vSAN 8.0x

Cause

After reviewing the following KB Instructions, disabling vSAN at the host level with CLI. There remove option was still unavailable in the UI.

 

The cause was sourced to Cluster Encryption setting mismatch. The vSAN vCenter Cluster setting was set to no Encryption after evaluation license expired. However, the setting did not sync to the ESXi hosts encryption setting with the Cluster setting. 

Enabling or Disabling a vSAN Cluster 

 

 

 

 

 

Resolution

With the help of Broadcom Global Support case. It was discovered instead that vCenter was in linked mode with multiple linked vCenter servers and the option was unavailable because the we were trying to remove the license from a linked vCenter and not the direct vCenter where the license was installed directly. 

 

It is required to be on the vCenter that the license is directed installed on. Once connected to the vCenter server that directly owned the license the option to "remove" was available and the administrator was successfully able to remove the license.

 

 

Additional Information

 

There are other circumstances where the license removal option is not available. See the following KB.

Removing License in vCenter if you are not able to remove from License Manager or JXplorer