3rd Party APP Error 400 client message authenticating with SEPM API
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3rd Party APP Error 400 client message authenticating with SEPM API

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Article ID: 390072

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Updated On:

Products

Endpoint Security Complete

Issue/Introduction

The error that is being returned is a 400 Client Error message when attempting to authenticate with the assigned SEPM username and password. The same account can successfully log into the SEPM without issue.

Found in the semapisrv_log.<date>.log:

[https-openssl-nio2-0.0.0.0-8446-exec-6] ERROR c.s.s.s.c.e.h.GlobalControllerExceptionHandler - EXCEPTION: Account is locked or invalid username, password, or domain. 
com.symantec.sepm.core.exception.InvalidArgumentException: Account is locked or invalid username, password, or domain.

Cause

A mismatch in the API files has occurred.

Resolution

  1. Stop all SEPM services
  2. Back up all files and folder from '<SEPM_HOME>\tomcat\instances\sepm-api\webapps'
  3. Delete all files from folder except sepm.war.new (files only, leave SEPM folder alone).
  4. Rename sepm.war.new to sepm.war
  5. Start all SEPM services
  6. Try to connect via API again.