Error during login process "Required storage module was not available to read"
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Error during login process "Required storage module was not available to read"

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Article ID: 390046

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Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

In Workbench, when creating a broker connection, users are getting an error message "Required storage module was not available to read".

Environment

CA Harvest SCM Workbench and Eclipse Plugin on the Windows platform.

Cause

The problem can have multiple causes that block the location of the “secure_storage” file that Workbench uses. In some cases, Workbench defaults to a location for which you do not have read/write permissions or the files have become locked.

Resolution

Resolution 1,

a) Close the workbench and using the Windows Explorer move the folders ".eclipse" and ".cascm" to a saved location.

b) Open the workbench and the folders will be automatically recreated. 

 

Resolution 2,

a) Move the file to another location.

b) Close the workbench.

c) In Windows Explorer, navigate to the folder where SCM is installed and open the “workbench.ini” file in Notepad. Then add the following 2 lines as the first 2 lines in the file, before the “-vmargs” line:

-eclipse.keyring

C:\Temp\.eclipse\org.eclipse.equinox.security\secure_storage

(if you want a different location for this file, just change the second line above to reflect that location.)

d) Save and close the file and then open the Workbench.