Bulkload jobs do not process following IDM startup--Cannot insert the value NULL into column during startup
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Bulkload jobs do not process following IDM startup--Cannot insert the value NULL into column during startup

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Article ID: 390009

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Updated On:

Products

CA Identity Manager

Issue/Introduction

During the Identity Manager startup, these errors appear in the log:

2025-03-04 13:07:38,291 ERROR [ims.tmt.persistence] (Thread-29 (ActiveMQ-client-global-threads)) PersistenceProvider: Thread-29 (ActiveMQ-client-global-threads): saveRuntimeStatusDetail: exception in saving the runtimestatusdetail: Cannot insert the value NULL into column 'eventID', table 'IMObjectStore_DB.dbo.runtimeStatusDetail12'; column does not allow nulls. INSERT fails. com.microsoft.sqlserver.jdbc.SQLServerException: Cannot insert the value NULL into column 'eventID', table 'IMObjectStore_DB.dbo.runtimeStatusDetail12'; column does not allow nulls. INSERT fails.

Environment

Identity Manager 14.5 

Cause

The JBoss Data folder did not clear up after migrating from wildfly15 to wildfly23.

This caused messages to become stuck in the JMS queue.

Resolution

Clear the JMS queue by deleting the JBoss ../data folder and restarting IM/Jboss.