Error when trying to reinstall the CA Service Desk Manager (CA SDM) ODBC services in Service Desk 14.1
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Error when trying to reinstall the CA Service Desk Manager (CA SDM) ODBC services in Service Desk 14.1

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Article ID: 39000

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

The following error occurs when attempting to reinstall CA Service Desk Manager ODBC Services in Service Desk 14.1:

[OpenAccess error 3145] The TCP port for the service could not be registered because it is registered for another network service.

The CA Service Desk Manager ODBC Services are being reinstalled since the 2 Windows Services (CA Service Desk Manager ODBC Agent and CA Service Desk Manager ODBC Data Access) cannot be started.

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component:

Cause

There is old information in the services.ini from a previous version. The services.ini file contains information that belongs to the previous version and is trying to use
OpenAccess 6 which is not supported in Service Desk 14.1 (users OpenAccess 7)

Resolution

  1. Uninstall the ODBC client and server services, from the CA SDM server run the following commands from the command prompt:

oa72_client_uninstall
oa72_server_uninstall

  1. Navigate to the 'Windows\System32\drivers\etc' directory and open SERVICES.INI with a text editor.
  2. Locate the following lines near the bottom of the file and delete them

OA6_19985 19985/tcp # OpenAccess 6 service CA Service Desk Manager ODBC Agent
OA6_19987 19987/tcp # OpenAccess 6 service CA Service Desk Manager ODBC Data Access

  1. Save changes
  2. Reinstall the ODBC client and server, from the CA SDM server run the following commands from the command prompt:

    oa72_server_setup
    oa72_client_setup
  3. Start the CA Service Desk Manager ODBC Agent and CA Service Desk Manager ODBC Data Access Windows Services again.