Search feature does not work in Service Point
search cancel

Search feature does not work in Service Point

book

Article ID: 389847

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

When searching for a keyword in Service Point, no Area/Category/Offering is found. Only KB's are found and displayed.

The SearchMS.log in the DEBUG level shows:

Request DefaultFullHttpRequest(decodeResult: success, version: HTTP/1.1, content: UnpooledHeapByteBuf(freed))
POST /sdm_index_pcat,catalog_index_service_offering/_search HTTP/1.1
content-type: application/json
content-length: 8277
host: <hostname>:<port>
accept: */*
user-agent: AHC/2.1

Response DefaultHttpResponse(decodeResult: success, version: HTTP/1.1)
HTTP/1.1 400 Bad Request
X-elastic-product: Elasticsearch

Environment

SDM 17.4 RU3

Service Point 17.4 RU3

Multi-Tenancy is enabled.

Cause

Defect with SDM 17.4 RU1, RU2 and RU3.

Resolution

This issue will be resolved in 17.4 RU4. The ETA for this RU is April 2025 (subject to change).