Spectrum alarms can't be cleared in portal
search cancel

Spectrum alarms can't be cleared in portal

book

Article ID: 389827

calendar_today

Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

When attempting to clear alarm's in Portal's alarm console it is not working and we see this in PCService.log

 

WARN  | qtp1465016019-997298     | 2025-02-03 21:37:30,478 | com.ca.im.portal.common.web.util.EmRestUtils                     
      | The Alarm Action Update webservice call failed
java.net.ConnectException: Connection refused
    at sun.nio.ch.Net.connect0(Native Method) ~[?:?]
    at sun.nio.ch.Net.connect(Unknown Source) ~[?:?]
    at sun.nio.ch.Net.connect(Unknown Source) ~[?:?]
    at sun.nio.ch.NioSocketImpl.connect(Unknown Source) ~[?:?]
    at java.net.Socket.connect(Unknown Source) ~[?:?]
    at java.net.Socket.connect(Unknown Source) ~[?:?]
    at sun.net.NetworkClient.doConnect(Unknown Source) ~[?:?]
    at sun.net.www.http.HttpClient.openServer(Unknown Source) ~[?:?]

Environment

Dx NetOps Performance Management 22.3.x and up

Cause

Event manager is configured for https

Resolution

Fixed in 24.3.6

Symptom: If HTTPS-based security is enabled for the Event Manager, you cannot click Acknowledge, Clear, or Troubleshooter in the Alarm Console Alarms view.
Resolution: With this fix, you can now acknowledge selected alarms, remove a selected alarm, and manage the troubleshooter assignments for a selected alarms when HTTPS-based security is enabled for the Event Manager.
(24.3.6, DE161772, 36060542)