Scheduler on a windows machine is down and when tried to restart it gives listener could not be started messages
search cancel

Scheduler on a windows machine is down and when tried to restart it gives listener could not be started messages

book

Article ID: 38982

calendar_today

Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys)

Issue/Introduction

Application server fails to start complaining about agent listener port.

CAUAJM_W_10134 CA WAAE Scheduler failed to establish a listener at host [hostname:49200]. Acquiring a new agent listener port...

CAUAJM_W_00002 Listener could not be started on port [0]. Proceeding... [msgSocket::msgSocket(server socket)(): 16: Devic

The following errors and messages are seen in event demon log:

CAUAJM_W_10134 CA WAAE Scheduler failed to establish a listener at host [hostname:49200]. Acquiring a new agent listener port... 

CAUAJM_W_00002 Listener could not be started on port [0]. Proceeding... [msgSocket::msgSocket(server socket)(): 16: Device or resource busy] 

CAUAJM_E_10125 CA WAAE Scheduler failed to establish a listener at host hostname. Exiting. 

CAUAJM_E_10498 CA WAAE scheduler failed to establish the required listeners. 

CAUAJM_I_40245 EVENT: ALARM ALARM: EP_SHUTDOWN 

 

 

 

Environment

Workload Automation AE on Windows

Cause

It occurs when Csam is stuck or is in CLOSE_WAIT state because the scheduler fails to catch up to the number of socket connections from the agents.

 

Resolution

Sometimes a reboot of the machine works for this error. The other solution (for Windows OS) is to follow the below procedure:

  1. Stop the scheduler and application server by stopping the services in services.msc
  2. Stop SSA i.e CA Connection Broker service.
  3. Check for csam processes. Open a command prompt and execute

          netstat -an |grep 7163

  1. Look for any processes on WAIT status and clear all of those processes.
  2. Restart CA Connection Broker, Scheduler and Application services.