How do I Configure a CAF plugin to run with a different account instead of the default Local System Account?

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Article ID: 3898

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager CA Server Automation

Issue/Introduction

In certain secure environments, the Local System Account may be restricted or have limited privileges.

The CAF plugin is configured to run with the Local System Account by default and therefore will not run in such environments. In such cases, the CAF plugins can be configured to use a different account.

Cause

The CAF Service (all plugins) runs using the Local System Account by default which may cause issues related to permissions when running software jobs requiring administrator permissions.

This document outlines how a CAF plugin (Software Delivery plugin in this case) can be configured to run with specific administrator credentials.

Environment

All supported Windows Operating SystemsCA Client Automation - All versions

Resolution

The following command is used to configure a CAF plugin to use different account:

caf setcreds <plugin> user <username> password <password>

Example: caf setcreds sdagent user administrator password abc12345!

**Note: In the above example "abc12345!" is the administrator password.

 

To backout the changes and set the plugin back to using the Local System Account,  you run the same command with no Username and Password

caf setcreds <plugin> 

Example: caf setcreds sdagent 

This will set the SDAgent to Run as Local System Account